大智慧底背顶背趋势主图指标公式

variable:p1=0;
DRAWGBKLAST(DATE900101,STRIP(RGB(49,79,111),RGB(52,73,85),0));
M:=121;
M2:=17;
M3:=166;
A1:=MA(((((((((MA(CLOSE,4)) + (MA(CLOSE,8))) + (MA(CLOSE,12))) + (MA(CLOSE,16))) + (MA(CLOSE,20))) + (MA(CLOSE,24))) + (MA(CLOSE,28))) / 7),M);
A2:=MA(A1,M2);
STICKLINE(((A1 - A2) 0),A1,A2,6,1),Color00EAEA;
STICKLINE(((A1 - A2) 0),A1,A2,6,1),Color54D110;
A:=EMA(SLOPE(EMA(CLOSE,55),10)*15+CLOSE,2);
SD:EMA(A,13),ColorFFaaBE,DOTLINE;
DD5:=FINANCE2( 35);
SS5:=FINANCE2( 37);
FF5:=FINANCE2(18);
GG5:=FINANCE2(3);
HH5:=DYNAINFO(39);
DRAWTEXTABS(10,10,STKLABEL+' '+STKNAME+' '+BKNAME),ColorFFaaBE;
DRAWTEXTREL(16,144,'市盈率:'+NUMTOSTRN(HH5,2)+'%'+' 每股收益:'+NUMTOSTRN(GG5,3)),ColorFFaaBE;
IF C0 AND DISPSTATUS=2 THEN
DRAWTEXTREL(16,100,'总股本:'+NUMTOSTRN(DD5,0)+'万股' +' 流通A股:'+NUMTOSTRN(SS5,0)+'万股'),ColorFFaaBE;
RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
k:=SMA(RSV,3,1);
d:=SMA(k,3,1);
A2:=BARSLAST(REF(CROSS(k,d),1));
B2:=REF(C,A2+1)C AND REF(k,A2+1)k AND CROSS(k,d);
DRAWTEXT(IF(B20,1,0),L-0.25,'kdj底背');
LC:=REF(CLOSE,3);
rsi1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)C AND REF(RSI1,A3+1)RSI1 AND CROSS(RSI1,RSI2);
DRAWTEXT(IF(B30,1,0),L-0.4,'RSI底背');
C2:=BARSLAST(REF(CROSS(d,K),1));
{MY指标公式网http://www.myzhibiao.com/}
D2:=REF(C,C2+1)C AND REF(k,C2+1)k AND CROSS(d,K);
DRAWTEXT(IF(D20,1,0),H+0.25,'KDJ顶背');
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(C,C3+1)C AND REF(RSI1,C3+1)RSI1 AND CROSS(RSI2,RSI1);
DRAWTEXT(IF(D30,1,0),H+0.4,'RSI顶背');
c1:=INTPART(cyc(5)*100*0.96)/100;
p2:=intpart(ref(cyc(5),1)*100)/100;
p3:=intpart(ref(cyc(5),1)*0.96*100)/100;
vv:=intpart(min(capital*0.05,ref(ma(vol,34),1))/100);
p40:=intpart(maxcyc*100)/100;
p41:=intpart(ref(MAXCYC,1)*100)/100;
p4:=p1=0 and cp2 or (ref(vol/100,1)vv and cintpart(p2*0.98*100)/100 and volmin(capital*0.05,ref(ma(vol,34),1)));
p5:=p1=1 and cmin(p3,p41);
p1:=if(p4=1,1,if(p5=1,0,ref(p1,1)));
DRAWTEXT(cross(p1,0),l*1,'㊣');
趋势:=(O+C)/2;
攻击线:MA(趋势,5),ColorFF33BE;
三日线:=MA(CLOSE,3);
操盘线:MA(趋势,9),Color3498CD;
魔鬼线:=MA(CLOSE,18);
生命线:=MA(CLOSE,27);
MA40:=MA(CLOSE,40);
决策线:MA(趋势,60);
趋势线:MA(CLOSE,120);
年线线:MA(CLOSE,260);
STICKLINE(三日线=攻击线 AND 三日线攻击线,攻击线,三日线,1,0),Color00D269;
STICKLINE(攻击线=决策线 AND 决策线=操盘线,操盘线,决策线,1,0);
STICKLINE(攻击线=操盘线 AND 攻击线=决策线,操盘线,攻击线,1,0);
STICKLINE(魔鬼线=决策线 AND 决策线=MA40,MA40,决策线,1,0),Color6C00D9;
STICKLINE(魔鬼线=MA40 AND 魔鬼线决策线,MA40,魔鬼线,1,0);
STICKLINE(攻击线=魔鬼线 AND 魔鬼线=操盘线,操盘线,魔鬼线,1,0);
STICKLINE(攻击线=操盘线 AND 攻击线魔鬼线,操盘线,攻击线,1,0);
a:=MA(CLOSE,7);
STICKLINE(三日线=攻击线 AND a=a,攻击线,a,1,0),Color00DBDB;
STICKLINE(三日线=攻击线 AND 操盘线=攻击线,攻击线,a,4,0),color4EE4CA; 大智慧底背顶背趋势主图指标公式的选股公式如下:
版权声明

本文仅代表作者观点,不代表MY指标公式网立场。
本文系作者授权MY指标公式网发表,未经许可,不得转载。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。本站无任何QQ群微信群

分享:

扫一扫在手机阅读、分享本文