大智慧电子股评主图指标公式

大智慧公式 2019-06-14 06:00:38 主图 股评
VA1:=IF((CLOSE 800),((AMOUNT / vol) / 100),((((CLOSE * 2) + HIGH) + LOW) / 4));
VA2:=((HHV(HIGH,15)) + (LLV(LOW,30))) / 2;
VA3:=EMA((MA(VA1,5)),10);
VA4:=EMA((MA(VA1,15)),10);
VA5:=EMA((MA(VA1,13)),21);
VA6:=((VA3 + VA4) + VA5) / 3;
波段线:EMA((MA(CLOSE,5)),5),COLORFB333F,LINETHICK2;
PARTLINE(波段线,波段线 (REF(波段线,3)),RGB(255,255,0)),LINETHICK2;
趋势线:((((REF(VA6,1)) + VA6) + (REF(VA6,2))) / 3);
PARTLINE(趋势线,CLOSE VA2,RGB(225,0,0),CLOSE = VA2,RGB(66,188,255)),COLORFFFF00,LINETHICK3;
天线:MA(REF(HHV(CLOSE,30),1),2),LINETHICK2,COLOR80E9FF;
地线:MA(REF(LLV(CLOSE,30),1),2),LINETHICK2,COLOR669900;
SD:=HHV(HIGH,13)=HIGH AND HIGHREF(HIGH,1);
SD1:=FILTER(SD,12);
SF:=LLV(LOW,13)=LOW AND LOWREF(LOW,1);
SF1:=FILTER(SF,12);
TSS1:=BARSLAST(SD1);
箱顶:REF(HIGH,TSS1),LINETHICK0,COLORRED;
TSS2:=BARSLAST(SF1);
箱底:REF(LOW,TSS2),LINETHICK0,COLORGREEN;
STICKLINE(OPEN=CLOSE,HIGH,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR005500;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR006600;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR007700;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR009900;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00BB00;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00DD00;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(CLOSEOPEN,HIGH,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,7,0) ,COLOR000055;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,6,0) ,COLOR000066;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,5,0) ,COLOR000077;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,4,0) ,COLOR000099;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,3,0) ,COLOR0000BB;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,2,0) ,COLOR0000DD;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,1,0) ,COLOR0000FF;
AA1:=MA(CLOSE,20);
AA2:=(CLOSE MA(CLOSE,5));
AA3:=(MA(CLOSE,5) MA(CLOSE,10));
AA4:=(CLOSE MA(CLOSE,10));
AA5:=(MA(CLOSE,5) MA(CLOSE,20));
AA6:=(CLOSE MA(CLOSE,20));
AA7:=REF(AA1,1);
AA8:=(AA1 AA7);
AAX:=(((((IF(AA2,10,(0 - 10)) + IF(AA3,10,(0 - 10))) + IF(AA4,10,(0 - 10))) + IF(AA5,10,(0 - 10))) + IF(AA6,10,(0 - 10))) + IF(AA8,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
T := BARSLAST(DISPSTATUS=1)+1;
IF BARSTATUS=2 AND C200 AND ((CROSS(AAX,1) AND (V1 = V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。'),COLORRED,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(AAX,1) AND (V1 V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。'),COLORYELLOW,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(AAX,1) AND (V1 V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。'),COLORYELLOW,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(AAX,1) AND (V1 = V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。'),COLORYELLOW,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(1,AAX) AND (V1 = V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(1,AAX) AND (V1 V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'随大盘一起下跌,呈明显缩量走势,考虑到大盘风险,减持或清仓。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(1,AAX) AND (V1 = V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'放量下跌,走势明显偏弱,离场观望。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(1,AAX) AND (V1 V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'缩量下跌,走势偏弱,离场观望。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX = 1) AND (REF(AAX,1) 0)) AND (V1 = V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'形态良好,强势明显,量能充足,可以继续持有。'),COLORRED,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX = 1) AND (REF(AAX,1) 0)) AND (V1 V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'上行趋势不变,强势依然,但量能开始转弱,注意风险。'),COLORRED,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX = 1) AND (REF(AAX,1) 0)) AND (V1 = V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'仍然具备上涨潜力,但股性偏弱,可考虑减仓。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX = 1) AND (REF(AAX,1) 0)) AND (V1 V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'走势趋弱,量能不足,减持大部分筹码。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX 1) AND (REF(AAX,1) 0)) AND (V1 = V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'形态不佳,注意成交量的变化,但目前不适合参与。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX 1) AND (REF(AAX,1) 0)) AND (V1 V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'趋势不明,股价偏弱,注意量能变化,目前不宜参与。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX 1) AND (REF(AAX,1) 0)) AND (V1 = V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'有走强迹象,但量能不足,趋势不明,不适合操作。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX 1) AND (REF(AAX,1) 0)) AND (V1 V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'走势太弱,没有参与价值。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (CROSS(AAX,1) AND (V1 = V2)) THEN
DRAWTEXTREL(500,20,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右,'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (CROSS(AAX,1) AND (V1 = V2)) THEN
DRAWTEXTREL(500,20,'如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (CROSS(AAX,1) AND (V1 V2)) THEN
DRAWTEXTREL(500,20,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌,'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (CROSS(AAX,1) AND (V1 V2)) THEN
DRAWTEXTREL(500,20,'可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (CROSS(1,AAX) AND (V1 = V2)) THEN
DRAWTEXTREL(500,20,'大盘形态走坏,重仓者可以减去大部分仓位。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (CROSS(1,AAX) AND (V1 V2)) THEN
DRAWTEXTREL(500,20,'大盘缩量调整,注意风险,短线清仓观望。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (((AAX = 1) AND (REF(AAX,1) 0)) AND (V1 = V2)) THEN
DRAWTEXTREL(500,20,'大盘走势良好,量能理想,可以继续持有强势股。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (((AAX = 1) AND (REF(AAX,1) 0)) AND (V1 V2)) THEN
DRAWTEXTREL(500,20,'大盘形态良好,但量能稍显不足,随时准备减仓。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (((AAX 1) AND (REF(AAX,1) 0)) AND (V1 = V2)) THEN
DRAWTEXTREL(500,20,'大盘趋势不明,注意成交量变化,目前不适宜进场。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (((AAX 1) AND (REF(AAX,1) 0)) AND (V1 V2)) THEN
DRAWTEXTREL(500,20,'大盘趋势向下,量能萎缩,不适合进场。'),COLOR8000FF,LINETHICK2,ALIGN1;
MA20:=MA(C,20);
MA40:=MA(C,40);
MA60:=MA(C,60);
bias:=(C-MA20)/MA20*100;
SHOPEN:=OPEN;
SHHIGH:=HIGH;
SHLOW:=LOW;
SHCLOSE:=CLOSE;
SHAMOUNT:=AMOUNT;
SHVOL:=VOL;
J12:=(HIGH - ((HIGH - LOW) / 3));
J23:=(LOW + ((HIGH - LOW) / 3));
T1:=(((IF((CLOSE = OPEN),1,0) + IF((CLOSE = J12),1,0)) + IF((CLOSE = J23),1,0)) 1);
T2:=((((CLOSE J23) AND (CLOSE J12)) AND (OPEN J23)) AND (OPEN J12));
T3:=((CLOSE = J12) AND (OPEN = J23));
T4:=(((OPEN = J12) AND (OPEN = J23)) AND (CLOSE J12));
T5:=(((OPEN = J23) AND (CLOSE = J12)) AND (CLOSE = J23));
T6:=((CLOSE = J23) AND (OPEN = J12));
T7:=(((OPEN = J12) AND (OPEN = J23)) AND (CLOSE J23));
T8:=(((OPEN = J12) AND (CLOSE = J12)) AND (CLOSE = J23));
T9:=(((SHAMOUNT / SHVOL) / 100) REF(HIGH,1));
T10:=(((SHAMOUNT / SHVOL) / 100) REF(LOW,1));
IF DISPSTATUS=2 THEN BEGIN;
GP:=' ';
IF T90 THEN GP:=GP+' 上涨趋势。';
IF T100 THEN GP:=GP+' 下跌趋势。';
IF T10 THEN GP:=GP+' 极端行情,在未来的几日内有85%的机会变更方向。';
IF T20 THEN GP:=GP+' 中性行情,多空双方都未能取得当日行情主动性的控制权';
IF T30 THEN GP:=GP+' 爬升行情,整个交易期间都有买方主导。';
IF T40 THEN GP:=GP+' 爬升行情,信息很少,但收盘期间是买方主导,其他未知。';
IF T50 THEN GP:=GP+' 爬升行情,买方把收盘价拉升到开盘价之上,卖方也在盘中主导一段行情,但不知道是谁主导最后的行情。';
IF T60 THEN GP:=GP+' 漂流行情,整个交易期间都有卖方主导。';
IF T70 THEN GP:=GP+' 漂流行情,信息很少,但收盘期间是卖方主导,其他未知。';
IF T80 THEN GP:=GP+' 漂流行情,卖方把收盘价压至到开盘价之下,买方也在盘中主导一段行情,但不知道是谁主导最后的行情。';
IF MA20=MA60 AND CROSS(MA40,MA60) THEN GP:=GP+' 形成季托,待股价回落到20天均线或40天均线时介入,20天均价为:'+MA20+',40天均价为:'+MA40+' 。';
IF BIAS9.5 AND (C-REF(C,1))/REF(C,1)*1009.8 THEN GP:=GP+' 短线涨幅过大,有整理要求。';
IF MA20=MA60 AND H=MA20 AND L=MIN(MA40,MA60) AND CO AND CREF(C,1) THEN GP:=GP+' 芙蓉出水,趋势向好。';
IF BIAS-18 AND (C-REF(C,1))/REF(C,1)*100-9.8 THEN GP:=GP+' 股价严重超跌,有爆发要求。';
IF BIAS-7 AND ALL(CLOSEOPEN,5) THEN GP:=GP+' 连收五阴,超跌有反弹要求。';
IF ABS(HIGH-REF(HIGH,1))/HIGH0.001 THEN GP:=GP+' 平顶,该高点有一定阻力。';
IF ABS(LOW-REF(LOW,1))/LOW0.001 AND ABS(REF(LOW,1)-REF(LOW,2))/REF(LOW,1)=0.00 THEN GP:=GP+' 平底,该低点有一定支撑。';
IF CLOSE=OPEN AND HIGHCLOSE AND LOWCLOSE AND HIGH/LOW 1.03 THEN GP:=GP+' 长十字,多空激争 前途未明。';
IF OPEN/CLOSE 1.05 AND HIGH/LOW OPEN/CLOSE+0.018 THEN GP:=GP+' 大阴烛,今日空方有绝对优势。';
IF REF(CLOSE,1)REF(OPEN,1) AND CLOSEOPEN AND CLOSE/OPEN0.98 THEN GP:=GP+' 双飞乌鸦,多头力竭,行情走软。';
IF (MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)0.667 THEN GP:=GP+' 长下影,下档支撑强或空方试探进攻。';
IF (HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)0.667 THEN GP:=GP+' 长上影,上档阻力大或多方试探进攻。';
IF CLOSE=OPEN AND CLOSE=LOW AND CLOSEHIGH THEN GP:=GP+' 垂死十字,在顶部时重要 表强力多头开始疲软。';
IF HIGH=CLOSE AND HIGHLOW THEN GP:=GP+' 光头阳线,今日尾盘多方气盛,行情可能延续到明天。';
IF (HIGHREF(LOW,1) OR LOWREF(HIGH,1)) THEN GP:=GP+' 跳空缺口,当日未补,有与跳空同向进行,上涨欲望强烈,三日内为回补观察期。';
IF LOW=CLOSE AND HIGHLOW THEN GP:=GP+' 赤脚阴线,尾盘空方胜。 注意股价下跌延续至次日。';
IF CLOSE=OPEN AND HIGHCLOSE AND LOWCLOSE AND HIGH CLOSE THEN GP:=GP+' 十字星,警告信号。原趋势停顿或反转,依上下影线长度判后市。';
IF CLOSE/OPEN1.05 AND HIGH/LOW CLOSE/OPEN+0.018 THEN GP:=GP+' 大阳烛,上升行情中意味行情剧烈向上攀升;下跌行情中意味行情剧烈向上反弹。';
IF REF(CLOSE,2)/REF(OPEN,2) 0.95 AND REF(OPEN,1) REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1)AND CLOSE/OPEN1.05 AND CLOSEREF(CLOSE,2) THEN
GP:=GP+' 早晨十字 - 如同晨星。 从看空平衡到看涨转强;左右跳空曰弃婴 。';
IF REF(CLOSE,4)/REF(OPEN,4)1.03 AND REF(CLOSE,3)REF(OPEN,3) AND REF(CLOSE,2)REF(OPEN,2) AND REF(CLOSE,1)REF(OPEN,1) AND REF(LOW,4)REF(LOW,3) AND REF(LOW,4)REF(LOW,2) AND REF(LOW,4)REF(LOW,1) AND REF(HIGH,4)REF(HIGH,3) AND REF(HIGH,4)REF(HIGH,2) AND REF(HIGH,4)REF(HIGH,1) AND CLOSE/OPEN1.03 AND CLOSEREF(CLOSE,4) THEN GP:=GP+' 上升三部曲,空方卖压被吸纳。 趋势易顺势走涨。';
IF (REF(HIGH,2) -REF(O,2))/REF(HIGH,2)=0.0003 AND (C-LOW)/O=0.0003 AND REF(C,2)REF(O,2) AND REF(C,2)REF(O,1) AND REF(C,1)O AND REF(C,1)REF(O,1) AND REF(HIGH,1)-REF(O,1)0 AND REF(LOW,1)-REF(C,1)0 AND HIGH-O0 AND REF(C,2)-REF(LOW,2)0 THEN GP:=GP+' 三胎乌鸦,多头走势被扭转。黑K价愈深量愈大,跳空愈大,反转信号愈强。';
IF ((REF(CLOSE,1)REF(OPEN,1) AND CLOSEOPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE0.002) OR (REF(CLOSE,1)REF(OPEN,1) AND CLOSEOPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE0.002)) THEN
GP:=GP+' 友好反攻 - 阴(阳)线结合,极线多方跳空向下(跳空向上)后反弹有企稳迹象 。';
IF CLOSEOPEN AND MIN(OPEN,CLOSE)=LOW AND HIGH-LOW 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE MA(CLOSE,5) THEN
GP:=GP+' 射击之星 - 如伴大量上遇阻力,有短期见顶可能,股价转疲。';
IF REF(CLOSE,1)-REF(OPEN,1)0 AND CLOSE-OPEN0 AND OPEN-REF(CLOSE,1)0 AND CLOSEREF(OPEN,1) AND CLOSEREF(CLOSE,1) AND CLOSE(REF(CLOSE,1)+REF(OPEN,1))/2 THEN
GP:=GP+' 贯穿线,多头力道的反扑或是空单回补力道。长阴线之后开低收在昨天1/2之上,为多头反转信号。';
IF ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) 0.04 AND ABS(CLOSE-OPEN)/CLOSE0.005 AND MAX(CLOSE,OPEN) MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) MIN(REF(CLOSE,1),REF(OPEN,1)) THEN
GP:=GP+' 身怀六甲 - 阴(阳)怀阳(阴),怪异的走势,显示该股行情可能转向。 若量由大转缩,下跌趋势更明确。';
IF (REF(C,1)-REF(O,1)0 AND C-O0 AND CREF(O,1) AND OREF(C,1)) THEN
GP:=GP+' 多头阳线吞噬,阳包阴。反转趋势需量能配合量。 ';
IF ((REF(C,2)-REF(O,2)0 AND (ABS(REF(C,2)-REF(O,2)))/(ABS(REF(C,3)-REF(O,3)))2.4 AND ABS(C-O)3 AND ABS(REF(C,2)-REF(O,2))(ABS(REF(C,1)-REF(O,1))) AND REF(C,1)-REF(O,1)0 AND C-O0 AND REF(O,1) REF(C,2) AND OREF(O,1) AND CREF(C,2) AND CREF(O,2)) OR (REF(C,2)-REF(O,2)0 AND (ABS(REF(C,2)-REF(O,2)))/(ABS(REF(C,3)-REF(O,3)))2.4 AND ABS(C-O)3 AND (ABS(REF(C,2)-REF(O,2)))(ABS(REF(C,1)-REF(O,1))) AND REF(C,1)-REF(O,1)0 AND C-O0 AND REF(C,1) REF(C,2) AND CREF(C,2) AND CREF(O,2) AND OREF(C,1))) THEN
GP:=GP+' 夜星 - 从看多平衡到看空转弱,转空。 ';
IF ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) 0.04 AND CLOSE=OPEN AND CLOSE MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE MIN(REF(CLOSE,1),REF(OPEN,1)) THEN
GP:=GP+' 十字胎 - 似身怀六甲,转向可能性更大,量缩观望为宜 。';
IF REF(C,1)REF(O,1) AND C-O0 AND CREF(H,1) AND OREF(L,1) AND REF(O,1)REF(MAX(O,C),2) AND REF(C,1)REF(MIN(O,C),2) AND REF(MAX(O,C),2)REF(MAX(O,C),3) THEN
GP:=GP+' 双人殉情 - 在上升趋势中最后之空头吞噬,也就是所谓的不见长红不回头。 ';
IF (REF(C,1)-REF(O,1)0 AND C-O0 AND CREF(O,1) AND OREF(C,1)) THEN
GP:=GP+' 阴线吞噬,阴包阳,向空反转。 ';
IF REF(CLOSE,1)/REF(OPEN,1)0.97 AND CLOSE/OPEN1.03 AND OPENREF(CLOSE,1) AND CLOSEREF(CLOSE,1) THEN GP:=GP+' 曙光,与乌云盖顶相反,行情将演化为V型反转或止跌横盘趋势 。';
IF (REF(C,1)-REF(O,1)0 AND C-O0 AND CREF(O,1) AND OREF(C,1)) THEN
GP:=GP+' 多头孕育线,阴育阳。多头反转可能。';
IF (REF(C,1)-REF(O,1)0 AND (ABS(REF(C,1)-REF(O,1)))/(ABS(REF(C,2)-REF(O,2)))2.4 AND C-O0 AND CREF(O,1) AND REF(C,1)-O2) THEN
GP:=GP+' 空头孕育线,阳育阴。看空 。';
IF (REF(C,1)-REF(O,1)0 AND C-O0 AND CREF(C,1) AND OREF(O,1) AND O-C 6) THEN
GP:=GP+' 空头孕育线,阴育阴。看空。';
IF REF(CLOSE,2)REF(OPEN,2) AND REF(CLOSE,1)REF(OPEN,1) AND CLOSEOPEN AND REF(CLOSE,1)REF(CLOSE,2) AND CLOSEREF(CLOSE,1) THEN
GP:=GP+' 三只乌鸦 - 强烈转空趋势,阴线越深量越大越易下跌。';
IF REF(CLOSE,4)/REF(OPEN,4)0.97 AND REF(CLOSE,3)REF(OPEN,3) AND REF(CLOSE,2)REF(OPEN,2) AND REF(CLOSE,1)REF(OPEN,1) AND REF(LOW,4)REF(LOW,3) AND REF(LOW,4)REF(LOW,2) AND REF(LOW,4)REF(LOW,1) AND REF(HIGH,4)REF(HIGH,3) AND REF(HIGH,4)REF(HIGH,2) AND REF(HIGH,4)REF(HIGH,1) AND CLOSE/OPEN0.97 AND CLOSEREF(CLOSE,4) THEN
GP:=GP+' 下跌三部曲,多方弱势不堪一击,趋势易顺势走跌。';
IF REF(CLOSE,4)/REF(OPEN,4)1.02 AND REF(CLOSE,3)REF(OPEN,3) AND REF(CLOSE,2)REF(OPEN,2) AND REF(CLOSE,1)REF(OPEN,1) AND REF(CLOSE,4)=REF(CLOSE,3) AND REF(HIGH,2)REF(HIGH,3) AND REF(LOW,2)=REF(OPEN,4) AND REF(HIGH,1)REF(CLOSE,4) AND REF(LOW,1)REF(OPEN,4) AND CLOSE/OPEN1.01 AND OPEN=REF(OPEN,1) AND CLOSE=REF(HIGH,3) THEN
GP:=GP+' 连续型态之执垫,比上升三法更具多头意义。';
IF REF(O,1)/REF(C,1) 1.05 AND REF(H,1)/REF(L,1) REF(O,1)/REF(C,1)+0.018 AND CO AND OREF(L,1) AND C=REF(L,1) THEN
GP:=GP+' 颈上线 - 下降趋势。若第二天大量,维持原趋势的可能性大增。';
IF (REF(C,1)-REF(O,1)0 AND (ABS(REF(C,1)-REF(O,1)))/(ABS(REF(C,2)-REF(O,2)))2.5 AND C-O0 AND CREF(O,1) AND C(REF(CLOSE,1)+REF(OPEN,1))/2 AND OREF(C,1)) THEN
GP:=GP+' 乌云罩顶 - 上涨遇重大阻力。空头聚力。';
IF (REF(C,1)-REF(O,1)0 AND C-O0 AND CREF(O,1) AND OREF(C,1)) THEN
GP:=GP+' 最后吞噬 - 在下降趋势中为一阴一阳组合,多头吞噬;在上升趋势中为一阳一阴组合,空头吞噬。';
IF REF(OPEN,1)REF(CLOSE,1) AND REF(CLOSE,2)/REF(OPEN,2) 0.95 AND REF(OPEN,1) REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)0.03 AND CLOSE/OPEN1.05 AND CLOSEREF(CLOSE,2) THEN
GP:=GP+' 晨星 - 多方势盛 变盘信号';
IF MIN(OPEN,CLOSE)=LOW AND HIGH-LOW 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE MA(CLOSE,5) THEN GP:=GP+' 倒转槌头 - 高位抛压或低位多空争执';
IF HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE MA(CLOSE,5) THEN GP:=GP+' 槌头 - 下影线有多头意义。在下降趋势之后看涨。注意反弹卖压 。';
IF HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE MA(CLOSE,5) THEN GP:=GP+' 吊颈线 - 高档看跌。';
IF ((REF(CLOSE,1)/REF(OPEN,1)1.03 AND CLOSE/OPEN0.96 AND CLOSEREF(OPEN,1) AND OPENREF(CLOSE,1)) OR (REF(CLOSE,1)/REF(OPEN,1)0.97 AND CLOSE/OPEN1.04 AND CLOSEREF(OPEN,1) AND OPENREF(CLOSE,1))) THEN
GP:=GP+' 穿头破脚 - 若第一根K为阴(阳) 表强劲上涨(下跌)力量。';
IF REF(OPEN,1)REF(CLOSE,1) AND REF(CLOSE,2)/REF(OPEN,2) 1.03 AND REF(OPEN,1) REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)0.02 AND CLOSE/OPEN0.97 AND CLOSEREF(CLOSE,2) THEN
GP:=GP+' 黄昏之星 - 空方势盛。反转信号,跳空成弃婴。';
IF REF(CLOSE,2)REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)=2/100 AND REF(OPEN,1)=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)=2/100 AND REF(OPEN,1)=REF(CLOSE,2) AND REF(CLOSE,1)=REF(OPEN,2) AND C=OPEN AND (CLOSE-OPEN)/OPEN=2/100 AND CLOSE=REF(OPEN,1) AND OPEN=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))=1/100 THEN GP:=GP+' 二阳夹一阴,必须从后续的走势来研判。';
IF OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))0 THEN
GP:=GP+' 分离 - 两日开盘相同 一阴一阳 变盘前彻底整理。';
IF ((OC AND OPENMA(C,5) AND OPENMA(C,10) AND OMA(C,20) AND CLOSEMA(C,5) AND CLOSEMA(C,10) AND CLOSEMA(C,20)) OR (OC AND OPENMA(C,5) AND OPENMA(C,10) AND OMA(C,20) AND CLOSEMA(C,5) AND CLOSEMA(C,10) AND CLOSEMA(C,20))) THEN GP:=GP+' 断头铡刀(出水芙蓉) -一根大阴(阳)线切断了三根均线 如果改变了其后均线的排列为空头(多头)排列 后势看空(多) 。';
END;
{MY指标公式网http://www.myzhibiao.com/}
TIPTEXT(DISPSTATUS=2,0,GP);
LC:=REF(CLOSE,1);
rsi1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
SELL1:=FILTER((CROSS(RSI1,88)),7);
SELL2:=(CROSS(88,RSI1));
kdj:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(KDJ,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
TYP:= (HIGH + LOW + CLOSE)/3;
cci:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DRAWTEXT(SELL1,HIGH*1.02,'预警'),COLORCC33CC,ALIGN2,VALIGN2;
DRAWTEXT(SELL2,HIGH*1.02,'▼'),COLORFFCC33,ALIGN1;
DRAWTEXT(SELL2 AND (K80 OR CCI160),HIGH*1.04,'▼'),COLORCC6633,ALIGN1;
DRAWTEXT(SELL2 AND K80 AND CCI160,HIGH*1.06,'▼'),COLORFF3300,ALIGN1;
VB1:=AMOUNT/V;
VB2:=LVB1*0.9;
VB3:=(C-REF(C,1))/REF(C,1)*1001.2;
VB4:=LMA(C,5)*0.921;
VB5:=VMA(V,5)*1.5;
VB6:=VB2 AND VB3 AND VB4 AND VB5;
VB7:=EMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,34)-LLV(LOW,27))*4,4)*25;
VB8:=IF((VB710),80,100);
VB9:=IF(K20,10,0);
VB10:=LLV(J,2)=LLV(J,8);
VB11:=IF(CROSS(J,REF(J+0.01,1)) AND VB10 AND J20,30,0);
DRAWTEXT(VB11 AND VB8=100 AND VB9=10,LOW*0.99,'超跌'),COLOR8000FF;
VB12:=C-REF(C,1);
VB13:=100*EMA(EMA(VB12,6),6)/EMA(EMA(ABS(VB12),6),6);
VB14:=IF(LLV(VB13,2)=LLV(VB13,7) AND COUNT(VB130,2) AND CROSS(VB13,MA(VB13,2)),1,0);
VB15:=FILTER((VB14=1 OR VB6),7);
VB16:=FILTER(VB6,5);
VB17:=FILTER(VB14=1,5);
DRAWTEXT(VB17,LOW*0.97,'短线'),COLOR66CCFF;
DRAWTEXT(VB16,LOW*0.98,'考虑介入'),COLOR336699,ALIGN2;
止损:=(LC*1.0035*97+0.2)/99.65;
DRAWTEXTABS(5,9,'止损价位: '+NUMTOSTRN(止损,2)+' 元'),COLORWHITE;
VC:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日阻力:=2*VC-LOW;
明日支撑:=2*VC-HIGH;
明日突破:=VC+(HIGH-LOW);
明日反转:=VC-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
DRAWTEXTABS(5,25,'今日阻力: '+NUMTOSTRN(今日阻力,2)+' 元'),COLOR00FF00;
DRAWTEXTABS(5,41,'今日支撑: '+NUMTOSTRN(今日支撑,2)+' 元'),COLORRED;
DRAWTEXTABS(5,57,'明日突破: '+NUMTOSTRN(明日突破,2)+' 元'),COLORYELLOW;
DRAWTEXTABS(5,73,'明日阻力: '+NUMTOSTRN(明日阻力,2)+' 元'),COLOR00FF00;
DRAWTEXTABS(5,89,'明日支撑: '+NUMTOSTRN(明日支撑,2)+' 元'),COLORRED;
DRAWTEXTABS(5,105,'明日反转: '+NUMTOSTRN(明日反转,2)+' 元'),COLORFFFF00;
HHVALL(HIGH)*1.1,COLOR000000;
LLVALL(LOW)*0.9,COLOR000000;
版权声明

本文仅代表作者观点,不代表MY指标公式网立场。
本文系作者授权MY指标公式网发表,未经许可,不得转载。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。本站无任何QQ群微信群

分享:

扫一扫在手机阅读、分享本文