大智慧高低错落主图指标公式

大智慧公式 2020-01-03 09:00:54 主图 买卖 画线
A1:=REF(HIGH,3)=HHV(HIGH,2*3+1);
B1:=FILTER(A1,3);
C1:=BACKSET(B1,3+1);
D1:=FILTER(C1,3);{MY指标公式网http://www.myzhibiao.com/}
A2:=REF(LOW,3)=LLV(LOW,2*3+1);
B2:=FILTER(A2,3);
C2:=BACKSET(B2,3+1);
D2:=FILTER(C2,3);{my指标公式网http://www.myzhibiao.com/}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;{MY指标公式网http://www.myzhibiao.com/}
H1:=(D1 AND NOT(D2 AND E1=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1E2));
H2:=D1 AND NOT(D2 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1REF(I1,1);{MY指标公式网http://www.myzhibiao.com/}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2REF(I2,1);{MY指标公式网http://www.myzhibiao.com/}
DRAWLINE(LD,L,HD,H,0),COLORWHITE,LINETHICK1,POINTDOT;
DRAWLINE(HD,H,LD,L,0),COLORWHITE,LINETHICK1,POINTDOT;
J1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HD),BARSLAST(LD))+1);
J2:=J1REF(J1,1);
DRAWLINE(J2,IF(HD,H,L),BARSTATUS=2,IF(BARSLAST(HD)BARSLAST(LD),H,L),0),COLORWHITE,LINETHICK1,POINTDOT;
A3:=HREF(H,REF(BARSLAST(HD),1)+1);
B3:=REF(H,REF(BARSLAST(HD),1)+1)REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));
D3:=A3 AND B3 AND HD;
E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2);
HH:=E3REF(E3,1);{MY指标公式网http://www.myzhibiao.com/}
A4:=LREF(L,REF(BARSLAST(LD),1)+1);
B4:=REF(L,REF(BARSLAST(LD),1)+1)REF(L,REF(BARSLAST(LD),1)+2+REF(BARSLAST(LD),REF(BARSLAST(LD),1)+2));
D4:=A4 AND B4 AND LD;
E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2);
LL:=E4REF(E4,1);{MY指标公式网http://www.myzhibiao.com/}
DRAWICON(HH,H,10),ALIGN1;
DRAWICON(LL,L,12),ALIGN1;
{MY指标公式网http://www.myzhibiao.com/}
H3:=HH OR BARSTATUS=2 OR BARSCOUNT(C)=1; {MY指标公式网http://www.myzhibiao.com/}
X3:=REF(BARSLAST(H3),1)+1;
F3:=BACKSET(H3 AND COUNT(LL,X3)0,LLVBARS(IF(LL,L,POW(10,20)),X3));
G3:=F3REF(F3,1);
I3:=BACKSET(G3,2);
LZ:=I3REF(I3,1); {MY指标公式网http://www.myzhibiao.com/}
L4:=LZ OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X4:=REF(BARSLAST(L4),1)+1;
F4:=BACKSET(L4 AND COUNT(HH,X4)0,HHVBARS(IF(HH,H,-POW(10,20)),X4));
G4:=F4REF(F4,1);
I4:=BACKSET(G4,2);
HZ:=I4REF(I4,1);{MY指标公式网http://www.myzhibiao.com/}
DRAWLINE(HZ,H,LZ,L,0),COLORGREEN,LINETHICK1;
DRAWLINE(LZ,L,HZ,H,0),COLORGREEN,LINETHICK1;{MY指标公式网http://www.myzhibiao.com/}
K1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HZ),BARSLAST(LZ))+1);
K2:=K1REF(K1,1);
DRAWLINE(K2,IF(HZ,H,L),BARSTATUS=2,C,0),COLORGREEN,LINETHICK1; {MY指标公式网http://www.myzhibiao.com/}
UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
VV:=UUREF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WWREF(WW,1);
DRAWLINE(XX,L,VV,L,1),COLORMAGENTA,LINETHICK1;
UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);
VV2:=UU2REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2REF(WW2,1);
DRAWLINE(XX2,H,VV2,H,1),COLORMAGENTA,LINETHICK1;
前一低:REF(L,BARSLAST(VV)),COLOR99FF66,POINTDOT,LINETHICK3;
前二低:REF(L,BARSLAST(XX)),COLORFF66FF,POINTDOT,LINETHICK3;
前一高:REF(H,BARSLAST(VV2)),COLOR99FF66,POINTDOT,LINETHICK3;
前二高:REF(H,BARSLAST(XX2)),COLORFF66FF,POINTDOT,LINETHICK3;
短高:=REF(H,BARSLAST(VV2));
短低:=REF(L,BARSLAST(VV));
短比: (C-短低)/(短高-短低),LINETHICK0;
常数:=REF(INDEXC,BARSLAST(VV))/REF(C,BARSLAST(VV));
叠1:INDEXC/常数,COLORGRAY,LINETHICK0;
PARTLINE(叠1,1),COLORGRAY;
常数2:=REF(INDEXC,BARSLAST(XX))/REF(C,BARSLAST(XX));
叠2:INDEXC/常数2,COLORGRAY,LINETHICK0;
PARTLINE(叠2,1),COLORGRAY;
s:=NUMTOSTRN(DAYS1970-DATETOD1970(REF( DATE,BARSLAST(LD) ) ),0 );
s1:=NUMTOSTRN(DAYS1970-DATETOD1970(REF( DATE,BARSLAST(HD) ) ),0 );
s2:=NUMTOSTRN(H,2 );
s3:=NUMTOSTRN(L,2 );
DRAWTEXT(HD,1.02*H,s),COLORCYAN;
DRAWTEXT(LD,0.98*L,s1),COLORCYAN;
DRAWTEXT(HD,H*(1+0.002),s2),COLORBLUE,ALIGN0;
DRAWTEXT(LD,L*(1.001-0.002),s3),COLORBLUE,ALIGN0;
{MY指标公式网http://www.myzhibiao.com/}
底:REF(L,BARSLAST(VV)),COLORred,LINETHICK2;
頂:REF(H,BARSLAST(VV2)),COLORGreen,LINETHICK2;
{MY指标公式网http://www.myzhibiao.com/}
StickLine(VV,頂,底,0,0),Colorff6633,linethick3;{MY指标公式网http://www.myzhibiao.com/}
DRAWLINE(VV2,H,VV,L,0),Colorff6633,linethick3;{MY指标公式网http://www.myzhibiao.com/}
DRAWLINE(VV2,H,VV,頂,0),Colorff6633,linethick3;{MY指标公式网http://www.myzhibiao.com/}
DRAWLINE(c0,H,VV,L,0),Colorcyan,linethick2;{MY指标公式网http://www.myzhibiao.com/}
DRAWLINE(c1,H,VV,頂,0),Colorcyan,linethick2;{MY指标公式网http://www.myzhibiao.com/}
{MY指标公式网http://www.myzhibiao.com/}
StickLine(VV2 ,頂,底,0,0),Colorred,linethick3;{MY指标公式网http://www.myzhibiao.com/}
DRAWLINE(VV,L,VV2,H,0),Colorred,linethick3;{MY指标公式网http://www.myzhibiao.com/}
DRAWLINE(VV,L,VV2,底,0),Colorred,linethick3;{MY指标公式网http://www.myzhibiao.com/};
stickline(co,(l+o)/2,(l+o)/2,4,1),coloryellow;
stickline(co,(c+h)/2,(c+h)/2,4,1),coloryellow;
stickline(co,(l+c)/2,(l+c)/2,4,1),colorwhite;
stickline(co,(o+h)/2,(o+h)/2,4,1),colorwhite;
stickline(co,(c+o)/2,(c+o)/2,4,1),colorred;
stickline(co,(c+o)/2,(c+o)/2,4,1),colorblue;
stickline(ref(co,1),ref((o+c)/2,1),ref((o+c)/2,1),9,2),colorblue,linethick2;
stickline(ref(co,1),ref((o+c)/2,1),ref((o+c)/2,1),9,2),coloryellow,linethick2;
DRAWTEXT(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),LOW*0.99,'B') , COLORRED;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.008,'S') ; 大智慧高低错落主图指标公式的选股公式如下:
版权声明

本文仅代表作者观点,不代表MY指标公式网立场。
本文系作者授权MY指标公式网发表,未经许可,不得转载。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。本站无任何QQ群微信群

分享:

扫一扫在手机阅读、分享本文