通达信稳不套主图指标公式

通达信指标 2018-10-23 06:00:22 主图 买卖
M2:=EMA(CLOSE,8);
生命价线:=EMA(M2,13),COLORGREEN,LINETHICK4;
MA5:=MA(C,5),COLORWHITE,LINETHICK1;
MA10:=MA(C,10),COLORBLUE,LINETHICK3;
MA20:=EMA(C,20);
MA99:=MA(C,99);
MA120:=MA(C,120);
MA250:=EMA(C,250),COLORBLUE,LINETHICK3;
VAR1AQ:=(CLOSE+HIGH+LOW)/3;
VAR2AQ:=EMA(VAR1AQ,14);
VAR3AQ:=REF(VAR2AQ,1);
VAR4AQ:=EMA(VAR1AQ,5),COLORMAGENTA,LINETHICK4;
多空趋势彩带2:DRAWBAND(生命价线,RGB(61,145,64),VAR2AQ,RGB(199,97,20));
多空趋势彩带3:DRAWBAND(VAR2AQ,RGB(56,94,15),VAR4AQ,RGB(255,97,0));
VV:=(C+L+H)/3;
Y311:=IFF(CURRBARSCOUNT=1,(XMA(VV,3)*3-MA(VV,2)+VV)/3,XMA(VV,3));
Y312:=IFF(CURRBARSCOUNT=1,(XMA(Y311,3)*3-MA(Y311,2)+Y311)/3,XMA(Y311,3));
Y313:=IFF(CURRBARSCOUNT=1,(XMA(Y312,3)*3-MA(Y312,2)+Y312)/3,XMA(Y312,3));
Y314:=IFF(CURRBARSCOUNT=1,(XMA(Y313,3)*3-MA(Y313,2)+Y313)/3,XMA(Y313,3));
Y315:=IFF(CURRBARSCOUNT=1,(XMA(Y314,3)*3-MA(Y314,2)+Y314)/3,XMA(Y314,3));
Y316:=IFF(CURRBARSCOUNT=1,(XMA(Y315,3)*3-MA(Y315,2)+Y315)/3,XMA(Y315,3));
Y317:=IFF(CURRBARSCOUNT=1,(XMA(Y316,3)*3-MA(Y316,2)+Y316)/3,XMA(Y316,3));
Y318:=IFF(CURRBARSCOUNT=1,(XMA(Y317,3)*3-MA(Y317,2)+Y317)/3,XMA(Y317,3));
Y319:=IFF(CURRBARSCOUNT=1,(XMA(Y318,3)*3-MA(Y318,2)+Y318)/3,XMA(Y318,3));
Y320:=IFF(CURRBARSCOUNT=1,(XMA(Y319,3)*3-MA(Y319,2)+Y319)/3,XMA(Y319,3));
Y321:=IFF(CURRBARSCOUNT=1,(XMA(Y320,3)*3-MA(Y320,2)+Y320)/3,XMA(Y320,3));
Y322:=IFF(CURRBARSCOUNT=1,(XMA(Y321,3)*3-MA(Y321,2)+Y321)/3,XMA(Y321,3));
Y323:=IFF(CURRBARSCOUNT=1,(XMA(Y322,3)*3-MA(Y322,2)+Y322)/3,XMA(Y322,3));
Y324:=IFF(CURRBARSCOUNT=1,(XMA(Y323,3)*3-MA(Y323,2)+Y323)/3,XMA(Y323,3));
Y325:=IFF(CURRBARSCOUNT=1,(XMA(Y324,3)*3-MA(Y324,2)+Y324)/3,XMA(Y324,3));
Y326:=IFF(CURRBARSCOUNT=1,(XMA(Y325,3)*3-MA(Y325,2)+Y325)/3,XMA(Y325,3));
Y327:=IFF(CURRBARSCOUNT=1,(XMA(Y326,3)*3-MA(Y326,2)+Y326)/3,XMA(Y326,3));
Y328:=IFF(CURRBARSCOUNT=1,(XMA(Y327,3)*3-MA(Y327,2)+Y327)/3,XMA(Y327,3));
Y329:=IFF(CURRBARSCOUNT=1,(XMA(Y328,3)*3-MA(Y328,2)+Y328)/3,XMA(Y328,3));
Y330:=IFF(CURRBARSCOUNT=1,(XMA(Y329,3)*3-MA(Y329,2)+Y329)/3,XMA(Y329,3));
Y331:=IFF(CURRBARSCOUNT=1,(XMA(Y330,3)*3-MA(Y330,2)+Y330)/3,XMA(Y330,3));
Y332:=IFF(CURRBARSCOUNT=1,(XMA(Y331,3)*3-MA(Y331,2)+Y331)/3,XMA(Y331,3));
Y333:=IFF(CURRBARSCOUNT=1,(XMA(Y332,3)*3-MA(Y332,2)+Y332)/3,XMA(Y332,3));
Y334:=IFF(CURRBARSCOUNT=1,(XMA(Y333,3)*3-MA(Y333,2)+Y333)/3,XMA(Y333,3));
Y335:=IFF(CURRBARSCOUNT=1,(XMA(Y334,3)*3-MA(Y334,2)+Y334)/3,XMA(Y334,3));
Y336:=IFF(CURRBARSCOUNT=1,(XMA(Y335,3)*3-MA(Y335,2)+Y335)/3,XMA(Y335,3));
Y337:=IFF(CURRBARSCOUNT=1,(XMA(Y336,3)*3-MA(Y336,2)+Y336)/3,XMA(Y336,3));
Y338:=IFF(CURRBARSCOUNT=1,(XMA(Y337,3)*3-MA(Y337,2)+Y337)/3,XMA(Y337,3));
Y339:=IFF(CURRBARSCOUNT=1,(XMA(Y338,3)*3-MA(Y338,2)+Y338)/3,XMA(Y338,3));
Y340:=IFF(CURRBARSCOUNT=1,(XMA(Y339,3)*3-MA(Y339,2)+Y339)/3,XMA(Y339,3));
Y341:=IFF(CURRBARSCOUNT=1,(XMA(Y340,3)*3-MA(Y340,2)+Y340)/3,XMA(Y340,3));
Y342:=IFF(CURRBARSCOUNT=1,(XMA(Y341,3)*3-MA(Y341,2)+Y341)/3,XMA(Y341,3));
Y343:=IFF(CURRBARSCOUNT=1,(XMA(Y342,3)*3-MA(Y342,2)+Y342)/3,XMA(Y342,3));
Y344:=IFF(CURRBARSCOUNT=1,(XMA(Y343,3)*3-MA(Y343,2)+Y343)/3,XMA(Y343,3));
Y345:=IFF(CURRBARSCOUNT=1,(XMA(Y344,3)*3-MA(Y344,2)+Y344)/3,XMA(Y344,3));
Y346:=IFF(CURRBARSCOUNT=1,(XMA(Y345,3)*3-MA(Y345,2)+Y345)/3,XMA(Y345,3));
Y347:=IFF(CURRBARSCOUNT=1,(XMA(Y346,3)*3-MA(Y346,2)+Y346)/3,XMA(Y346,3));
Y348:=IFF(CURRBARSCOUNT=1,(XMA(Y347,3)*3-MA(Y347,2)+Y347)/3,XMA(Y347,3));
Y349:=IFF(CURRBARSCOUNT=1,(XMA(Y348,3)*3-MA(Y348,2)+Y348)/3,XMA(Y348,3));
Y350:=IFF(CURRBARSCOUNT=1,(XMA(Y349,3)*3-MA(Y349,2)+Y349)/3,XMA(Y349,3));
Y351:=IFF(CURRBARSCOUNT=1,(XMA(Y350,3)*3-MA(Y350,2)+Y350)/3,XMA(Y350,3));
Y352:=IFF(CURRBARSCOUNT=1,(XMA(Y351,3)*3-MA(Y351,2)+Y351)/3,XMA(Y351,3));
Y353:=IFF(CURRBARSCOUNT=1,(XMA(Y352,3)*3-MA(Y352,2)+Y352)/3,XMA(Y352,3));
Y354:=IFF(CURRBARSCOUNT=1,(XMA(Y353,3)*3-MA(Y353,2)+Y353)/3,XMA(Y353,3));
Y355:=IFF(CURRBARSCOUNT=1,(XMA(Y354,3)*3-MA(Y354,2)+Y354)/3,XMA(Y354,3));
Y356:=IFF(CURRBARSCOUNT=1,(XMA(Y355,3)*3-MA(Y355,2)+Y355)/3,XMA(Y355,3));
Y357:=IFF(CURRBARSCOUNT=1,(XMA(Y356,3)*3-MA(Y356,2)+Y356)/3,XMA(Y356,3));
Y358:=IFF(CURRBARSCOUNT=1,(XMA(Y357,3)*3-MA(Y357,2)+Y357)/3,XMA(Y357,3));
Y359:=IFF(CURRBARSCOUNT=1,(XMA(Y358,3)*3-MA(Y358,2)+Y358)/3,XMA(Y358,3));
Y360:=IFF(CURRBARSCOUNT=1,(XMA(Y359,3)*3-MA(Y359,2)+Y359)/3,XMA(Y359,3));
Y361:=IFF(CURRBARSCOUNT=1,(XMA(Y360,3)*3-MA(Y360,2)+Y360)/3,XMA(Y360,3));
Y362:=IFF(CURRBARSCOUNT=1,(XMA(Y361,3)*3-MA(Y361,2)+Y361)/3,XMA(Y361,3));
Y363:=IFF(CURRBARSCOUNT=1,(XMA(Y362,3)*3-MA(Y362,2)+Y362)/3,XMA(Y362,3));
Y364:=IFF(CURRBARSCOUNT=1,(XMA(Y363,3)*3-MA(Y363,2)+Y363)/3,XMA(Y363,3));
Y365:=IFF(CURRBARSCOUNT=1,(XMA(Y364,3)*3-MA(Y364,2)+Y364)/3,XMA(Y364,3));
Y366:=IFF(CURRBARSCOUNT=1,(XMA(Y365,3)*3-MA(Y365,2)+Y365)/3,XMA(Y365,3));
Y367:=IFF(CURRBARSCOUNT=1,(XMA(Y366,3)*3-MA(Y366,2)+Y366)/3,XMA(Y366,3));
Y368:=IFF(CURRBARSCOUNT=1,(XMA(Y367,3)*3-MA(Y367,2)+Y367)/3,XMA(Y367,3));
Y369:=IFF(CURRBARSCOUNT=1,(XMA(Y368,3)*3-MA(Y368,2)+Y368)/3,XMA(Y368,3));
Y370:=IFF(CURRBARSCOUNT=1,(XMA(Y369,3)*3-MA(Y369,2)+Y369)/3,XMA(Y369,3));
Y371:=IFF(CURRBARSCOUNT=1,(XMA(Y370,3)*3-MA(Y370,2)+Y370)/3,XMA(Y370,3));
Y372:=IFF(CURRBARSCOUNT=1,(XMA(Y371,3)*3-MA(Y371,2)+Y371)/3,XMA(Y371,3));
Y373:=IFF(CURRBARSCOUNT=1,(XMA(Y372,3)*3-MA(Y372,2)+Y372)/3,XMA(Y372,3));
Y374:=IFF(CURRBARSCOUNT=1,(XMA(Y373,3)*3-MA(Y373,2)+Y373)/3,XMA(Y373,3));
Y375:=IFF(CURRBARSCOUNT=1,(XMA(Y374,3)*3-MA(Y374,2)+Y374)/3,XMA(Y374,3));
Y376:=IFF(CURRBARSCOUNT=1,(XMA(Y375,3)*3-MA(Y375,2)+Y375)/3,XMA(Y375,3));
Y377:=IFF(CURRBARSCOUNT=1,(XMA(Y376,3)*3-MA(Y376,2)+Y376)/3,XMA(Y376,3));
Y378:=IFF(CURRBARSCOUNT=1,(XMA(Y377,3)*3-MA(Y377,2)+Y377)/3,XMA(Y377,3));
Y379:=IFF(CURRBARSCOUNT=1,(XMA(Y378,3)*3-MA(Y378,2)+Y378)/3,XMA(Y378,3));
Y380:=IFF(CURRBARSCOUNT=1,(XMA(Y379,3)*3-MA(Y379,2)+Y379)/3,XMA(Y379,3));
Y381:=IFF(CURRBARSCOUNT=1,(XMA(Y380,3)*3-MA(Y380,2)+Y380)/3,XMA(Y380,3));
Y382:=IFF(CURRBARSCOUNT=1,(XMA(Y381,3)*3-MA(Y381,2)+Y381)/3,XMA(Y381,3));
Y383:=IFF(CURRBARSCOUNT=1,(XMA(Y382,3)*3-MA(Y382,2)+Y382)/3,XMA(Y382,3));
Y384:=IFF(CURRBARSCOUNT=1,(XMA(Y383,3)*3-MA(Y383,2)+Y383)/3,XMA(Y383,3));
Y385:=IFF(CURRBARSCOUNT=1,(XMA(Y384,3)*3-MA(Y384,2)+Y384)/3,XMA(Y384,3));
Y386:=IFF(CURRBARSCOUNT=1,(XMA(Y385,3)*3-MA(Y385,2)+Y385)/3,XMA(Y385,3));
Y387:=IFF(CURRBARSCOUNT=1,(XMA(Y386,3)*3-MA(Y386,2)+Y386)/3,XMA(Y386,3));
Y388:=IFF(CURRBARSCOUNT=1,(XMA(Y387,3)*3-MA(Y387,2)+Y387)/3,XMA(Y387,3));
Y389:=IFF(CURRBARSCOUNT=1,(XMA(Y388,3)*3-MA(Y388,2)+Y388)/3,XMA(Y388,3));
Y390:=IFF(CURRBARSCOUNT=1,(XMA(Y389,3)*3-MA(Y389,2)+Y389)/3,XMA(Y389,3));
Y391:=IFF(CURRBARSCOUNT=1,(XMA(Y390,3)*3-MA(Y390,2)+Y390)/3,XMA(Y390,3));
Y392:=IFF(CURRBARSCOUNT=1,(XMA(Y391,3)*3-MA(Y391,2)+Y391)/3,XMA(Y391,3));
Y393:=IFF(CURRBARSCOUNT=1,(XMA(Y392,3)*3-MA(Y392,2)+Y392)/3,XMA(Y392,3));
Y394:=IFF(CURRBARSCOUNT=1,(XMA(Y393,3)*3-MA(Y393,2)+Y393)/3,XMA(Y393,3));
Y395:=IFF(CURRBARSCOUNT=1,(XMA(Y394,3)*3-MA(Y394,2)+Y394)/3,XMA(Y394,3));
Y396:=IFF(CURRBARSCOUNT=1,(XMA(Y395,3)*3-MA(Y395,2)+Y395)/3,XMA(Y395,3));
Y397:=IFF(CURRBARSCOUNT=1,(XMA(Y396,3)*3-MA(Y396,2)+Y396)/3,XMA(Y396,3));
Y398:=IFF(CURRBARSCOUNT=1,(XMA(Y397,3)*3-MA(Y397,2)+Y397)/3,XMA(Y397,3));
Y399:=IFF(CURRBARSCOUNT=1,(XMA(Y398,3)*3-MA(Y398,2)+Y398)/3,XMA(Y398,3));
Y400:=IFF(CURRBARSCOUNT=1,(XMA(Y399,3)*3-MA(Y399,2)+Y399)/3,XMA(Y399,3));
Y401:=IFF(CURRBARSCOUNT=1,(XMA(Y400,3)*3-MA(Y400,2)+Y400)/3,XMA(Y400,3));
Y402:=IFF(CURRBARSCOUNT=1,(XMA(Y401,3)*3-MA(Y401,2)+Y401)/3,XMA(Y401,3));
Y403:=IFF(CURRBARSCOUNT=1,(XMA(Y402,3)*3-MA(Y402,2)+Y402)/3,XMA(Y402,3));
Y404:=IFF(CURRBARSCOUNT=1,(XMA(Y403,3)*3-MA(Y403,2)+Y403)/3,XMA(Y403,3));
Y405:=IFF(CURRBARSCOUNT=1,(XMA(Y404,3)*3-MA(Y404,2)+Y404)/3,XMA(Y404,3));
Y406:=IFF(CURRBARSCOUNT=1,(XMA(Y405,3)*3-MA(Y405,2)+Y405)/3,XMA(Y405,3));
LL:Y406,POINTDOT;
险2:=Y396*1.125,COLORYELLOW,POINTDOT;
良2:=Y396*0.875,COLORGREEN,POINTDOT;
AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
通道1:=AA*102/100;
通道2:=AA*(200-102)/30;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=dma(CLOSE,CC);
通道3:=(1+7/100)*DD;
通道4:=(1-7/100)*DD;
股价:=C;
股价运动:=股价,LINETHICK2,COLORBLUE;
运动趋势:=Y406,LINETHICK1,COLORWHITE;
高风险区3:运动趋势*1.15,POINTDOT,COLORRED,LINETHICK3;
良机区3:运动趋势*0.85,POINTDOT,COLORGREEN,LINETHICK3;
涨幅:=(C-REF(C,1))/C*100;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,L-0.1,7);
DRAWICON(SEL,H+0.1,8);
STICKLINE(买线=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线=卖线,CLOSE,OPEN,2,0),COLORRED;
STICKLINE(买线卖线,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(买线卖线,CLOSE,OPEN,2,0),COLORGREEN;
STICKLINE(BU,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(SEL,OPEN,CLOSE,2,0),COLORBLUE;
主力:=EMA(CLOSE,10),COLORRED,LINETHICK2;
散户:=EMA(CLOSE,5),COLORWHITE,LINETHICK1;
绿降:=(46.18*EMA(CLOSE,10)-31.82*EMA(CLOSE,4))/14.36,COLORGREEN,LINETHICK1; {my指标公式网-股票公式网站 www.myzhibiao.com}
操盘:=MA(CLOSE,9),COLORCYAN,LINETHICK2;
界点:=MA(CLOSE,20),COLORRED,LINETHICK3;
快慢线:=EMA(EMA(EMA(EMA(CLOSE,2),2),2),2),LINETHICK4,COLOR0000FF;
慢快线:=EMA(REF(快慢线,1),2),LINETHICK2,COLOR00FFFF;
快慢彩带:DRAWBAND(慢快线,RGB(0,0,255),快慢线,RGB(255,0,0));
MA34:=MA(C,34),COLORBLUE,LINETHICK4;
EMA250:EMA(C,250),COLORBLUE,LINETHICK3;
F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(CREF(O,1) AND F0,1,0);
P1:=今小昨;
今小前:=IF(CREF(O,2) AND F0,1,0);
P2:=今小前;
转向点:=P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1 AND CROSS(ZIG(3,3) ,REF(ZIG(3 ,3),1));
N:=5;
BUC:=BARSLAST(CLOSE=HHV(CLOSE,N));
SEC:=BARSLAST(CLOSE=LLV(CLOSE,N));
KK1:=SEC;
KK2:=BUC;
LM1:=SEC;
LM2:=BUC;
OK:=KK1KK2 AND LM1LM2;
OK1:=KK1KK2 AND LM1LM2;
NOK:=KK2KK1 AND LM2LM1;
NOK1:=KK2KK1 AND LM2LM1;
VAR1:=(C+H+O+L)/4;
AA1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,30))/MA(CLOSE,30);
JAX:=DMA(CLOSE,AA1);
压力线:=(1+9/100)*JAX;
支撑线:=(1-9/100)*JAX;
NA1:=2;
K1A1:=HHV(H,NA1);
K2A1:=LLV(L,NA1);
FCA1:=CLOSE;
AD1:=BARSLAST(FCA1REF(K1A1,1));
BA1:=BARSLAST(FCA1REF(K2A1,1));
JRA1:=IF(AD1BA1,K1A1,K2A1);
KB:=IF(CJRA1,JRA1*0.998,JRA1*1.002),COLORYELLOW;
变蓝:=CKB;
STICKLINE(OK1,CLOSE,OPEN,2,0),COLORGREEN;
STICKLINE(OK,CLOSE,OPEN,2,0),COLOR000099;
STICKLINE(OK,CLOSE,OPEN,0.5,1),COLOR0000DD;
STICKLINE(OK,HIGH,LOW,0.0,1),COLOR0000FF;
STICKLINE(NOK ,CLOSE,OPEN,2,0),COLOR00BB00;
STICKLINE(NOK ,CLOSE,OPEN,0.5,0),COLOR00FF00;
STICKLINE(涨幅-4.00,CLOSE,OPEN,2,0),COLOR00BB00;
STICKLINE(涨幅-4.00,CLOSE,OPEN,0.5,0),COLOR00FF00;
VAR2SK:=(2*CLOSE+HIGH+LOW)/4;
VAR3SK:=IF(YEAR=2099 AND MONTH2,0,1);
VAR4SK:=LLV(LOW,5);
VAR5SK:=HHV(HIGH,4);
散户A:=EMA((VAR2SK-VAR4SK)/(VAR5SK-VAR4SK)*100,4)*VAR3SK;
庄家:=EMA(0.667*REF(散户A,1)+0.333*散户A,2)*VAR3SK;
VAR1XG:=REF(C,1);
VAR2XG:=SMA(MAX(C-VAR1XG,0),7,1)/SMA(ABS(C-VAR1XG),7,1)*1000;
VAR3XG:=DRAWLINE(VAR2XG=HHV(VAR2XG,7),VAR2XG,VAR2XG=LLV(VAR2XG,7),VAR2XG,1);
VAR4XG:=VAR2XG=VAR3XG;
VAR5XG:=VAR2XGREF(VAR2XG,1);
变粉:=(VAR4XG AND VAR5XG) OR (CROSS(0.9,1/vol*10000.01 AND kdj.J0))
OR (CROSS(散户A,庄家) AND 散户A30);
STICKLINE(变粉 AND OC,CLOSE,OPEN,2,1),COLORMAGENTA;
DRAWTEXT(CROSS(KK1,KK2),L*0.99,'B'),COLORYELLOW,LINETHICK3;
DRAWTEXT(CROSS(KK2,KK1),H*1.01,'S'),COLORCYAN,LINETHICK3;
STICKLINE(转向点,OPEN,CLOSE,2,0),COLORFF11FF;
STICKLINE(转向点,OPEN,CLOSE,1,0),COLORFF44FF;
STICKLINE(转向点,O,C,0.5,0),COLORFF66FF;
VAR13HM:=ZIG(3,22)REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)=REF(ZIG(3,22),3);
DRAWTEXT(VAR13HM,L,'★黑马介入点'), COLORCYAN;
VAR6:=KDJ.J#WEEK(9,3,3);
VAR8:=KDJ.J#MONTH(9,3,3);
DEA7:=macd.DEA#WEEK;
DIFF7:=MACD.DIF#WEEK;
D7:=DIFF7-DEA7;
DEA8:=MACD.DEA#MONTH;
DIFF8:=MACD.DIF#MONTH;
D8:=DIFF8-DEA8;
黑马抄底A:=IF(CROSS(VAR6,0) AND D80 OR CROSS(VAR8,0) AND D70,5,0),COLORYELLOW;
DRAWTEXT(黑马抄底A,L*0.99,'●黑马抄底'),COLORYELLOW;
bias1 :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
三浪三:=IF(HHV(C,8)/LLV(C,8)1.03 AND MA(C,5)MA(C,10)
AND MA(C,5)/MA(C,10)1.012 AND MA(C,5)/MA(C,10)0.988
AND LOW/MA(C,20)1.004 AND LOW/MA(C,20)0.997
AND MA(C,20)MA(C,30)AND BIAS14.5,1,0);
DRAWTEXT(三浪三,H*0.99,'●三浪三'),COLORMAGENTA;
黄珠买:IF(VAR2AQVAR3AQ,VAR2AQ,DRAWNULL), POINTDOT,LINETHICK4, COLORYELLOW;
蓝珠卖:IF(VAR2AQVAR3AQ,VAR3AQ,DRAWNULL),POINTDOT,LINETHICK4, COLORCYAN;
MA34A:MA(C,34),COLORMAGENTA,LINETHICK3;
黑马买线:=EMA(C,3);
黑马卖线:=EMA(SLOPE(C,20)*10+C,35);
黑马交叉A:=CROSS(黑马买线,黑马卖线);
VAR1BD:=(CLOSE*2+HIGH+LOW)/4;
SK:=EMA(VAR1BD,13)-EMA(VAR1BD,73);
SD:=EMA(SK,2);
DX1:=CROSS(SK,SD) AND SK-0.04 AND (C-REF(C,1))/REF(C,1)*100=3;
DX2:=CROSS(SK,SD) AND SK=-0.14;
DX3:=CROSS(SK,SD) AND SK=0.05 AND (V/MA(V,5)2 OR (C-REF(C,1))/REF(C,1)*100=3.5);
短线:=(DX1 OR DX2 OR DX3)*0.5,POINTDOT,COLOR00FF00,LINETHICK0;
买入BD:=(CROSS(SK,SD)
AND BARSLAST(CROSS(SD,SK))=8)*0.2,POINTDOT,COLORWHITE,LINETHICK0;
加码:=(CROSS(SK,SD)
AND BARSLAST(CROSS(SD,SK))8)*0.3,POINTDOT,COLORYELLOW,LINETHICK0;
波段点:=(短线0 AND 买入BD0) OR (短线0 AND 加码0) OR (短线0 AND 黑马交叉A)
OR (加码0 AND 买入BD0) OR (加码0 AND 黑马交叉A) OR (买入BD0 AND 黑马交叉A);
STICKLINE(加码0 OR BU,O,C,2,0),LINETHICK2,COLORWHITE;
STICKLINE(波段点,(C+O)/2,C,2,1),LINETHICK2,COLORYELLOW;
STICKLINE(SEL,O,C,2,0),LINETHICK2,COLORCC0000;
STICKLINE(SEL,O,C,0.5,0),LINETHICK2,COLORFF8800;
RSVA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)),LINETHICK;
KA:=SMA(RSVA,3,1),LINETHICK1;
DA:=SMA(KA,3,1),LINETHICK1;
DRAWICON(CROSS(DA,KA) AND (涨幅-4.00 OR NOK OR 买线卖线),H,8);
DIFA:=EMA(CLOSE,9)-EMA(CLOSE,18),LINETHICK1,COLORYELLOW;
DEAB:=EMA(DIFA,7),LINETHICK1,COLORWHITE;
DRAWTEXT(CROSS(DIFA,DEAB),L,'◎-----'),LINETHICK3,COLORGREEN;
稳不套:=CROSS(VAR4AQ,生命价线) AND 快慢线慢快线 AND C快慢线;
DRAWTEXT(稳不套,L*0.99,'●稳不套'),COLORCYAN;
版权声明

本文仅代表作者观点,不代表MY指标公式网立场。
本文系作者授权MY指标公式网发表,未经许可,不得转载。

分享:

扫一扫在手机阅读、分享本文