通达信多空十九彩带云主图指标公式

通达信指标 2019-08-13 12:00:21 波段 主图
X1:=(CLOSE+LOW+HIGH)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
VAR2:=EMA(EMA(X1,1),13);
VAR3:=EMA(VAR2,21);
STICKLINE(VAR2=VAR3,VAR2,VAR3,8,0),COLORRED;
STICKLINE(VAR2VAR3,VAR2,VAR3,8,0),COLORCYAN;
XCLOSE:=EMA((OPEN+HIGH+LOW+CLOSE)/4,3);
XOPEN:=EMA((REF(OPEN,1)+REF(XCLOSE,1))/2,3);
TEMPG:=MAX(HIGH,XOPEN);
XHIGH:=EMA(MAX(TEMPG,XCLOSE),3);
TEMP:=MIN(LOW,XOPEN);
XLOW:=EMA(MIN(TEMP,XCLOSE),3);
O1:=IF(XOPENXCLOSE,XOPEN,XCLOSE);
C1:=IF(XOPENXCLOSE,XCLOSE,XOPEN);
STICKLINE(XOPEN=XCLOSE,XHIGH,XLOW,0.1,0),COLORGREEN;
STICKLINE(XOPEN=XCLOSE,C1,O1,6,0),COLORGREEN;
STICKLINE(XOPENXCLOSE,XHIGH,XLOW,0.1,0),COLORMAGENTA;
STICKLINE(XOPENXCLOSE,C1,O1,6,0),COLORMAGENTA;
AC:=CLOSE;
转强:=(HIGH,4);
转弱:=(LOW,4);
B:=CLOSE*0;
转折线:IF(B=-1,MA(HIGH,6),MA(LOW,6)),LINETHICK1,COLORYELLOW;
趋势:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55);
OP:=MA(X1,5);
REFOP:=REF(OP,1); MA4:=MA(CLOSE,4);
MA8:=MA(CLOSE,8);
MA13:=MA(CLOSE,13);
MA110:=MA(CLOSE,110); C2:=HHV(C1,2);
C3:=LLV(C1,1);
ET:=HHV(C1,2);
ET1:=REF(ET,1);
XB:=LLV(C1,1);
XB1:=REF(XB,1);
M:=BARSLAST(CLOSEXB AND C1=XB1);
M11:=REF(M,1);
N9:=BARSLAST(CLOSEET AND C1=ET1);
N1:=REF(N9,1);
M21:=BARSLAST(M-N90 AND M11=N1)+1;
N2:=BARSLAST(N9-M0 AND N1=M11)+1;
ET2:=HHV(ET,M21);
XB2:=LLV(XB,N2);
A:=IF(M-N90 AND M11=N1,1,IF(N9-M0 AND N1=M11,0,2));
H1:=IF(M-N90,CLOSE,ET2);
H2:=IF(A=1,CLOSE,C2);
H3:=IF(M-N90,CLOSE,XB2);
H4:=IF(A=1,CLOSE,XB2);
H5:=IF(M-N90 OR A=1,CLOSE,H3);
H6:=REF(H5,1);
H7:=REF(H5,2);
H8:=H5H6;
H9:=H4=REF(H4,1) AND REF(H4,1)REF(H4,2) AND H5REF(H5,2);
H10:=H2=REF(H2,1) AND H4=REF(H4,1) AND H5=REF(H5,2);
W:=H8 OR H9 OR H10;
T9:=H5H6 AND H5REF(H5,2);
T10:=H4=REF(H4,1) AND H5REF(H5,2);
T11:=H3REF(H3,1) AND H5REF(H5,1);
T12:=H5=REF(H5,1) AND H3=H4;
T13:=H2=REF(H2,1) AND H2=H5;
TW:=T9 OR T10 OR T11 OR T12 OR T13;
BBP:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)) *100;
版权声明

本文仅代表作者观点,不代表MY指标公式网立场。
本文系作者授权MY指标公式网发表,未经许可,不得转载。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。本站无任何QQ群微信群

分享:

扫一扫在手机阅读、分享本文