通达信买量极限度指标公式

通达信指标 2019-08-14 06:01:02 成交量
N:=106;N1:=83;
AA:=IF(DATE=1091231,1,0);
BB:=FLOOR(SUM(V/CAPITAL,0));
【手】:vol,LINETHICK,COLOR00FFFF;
CC:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,CC,0,-1,-1),COLOR00C0C0;{MY指标公式网http://www.myzhibiao.com/}
额【亿】:AMOUNT/100000000,NODRAW;
CB:=IF(CAPITAL1,AMOUNT/VOL/100,(HIGH+LOW+2*CLOSE)/4);
空1:=IF((HIGH-LOW)0 AND CLOSECB, ((HIGH-CLOSE)/(HIGH-CB))*((HIGH-CLOSE)/(HIGH-CB))*((HIGH-CB)/(HIGH-LOW)*VOL) ,0);
{my指标公式网http://www.myzhibiao.com/}
多1:=IF((HIGH-LOW)0 AND CLOSECB, VOL-空1 ,0);
多2:=IF((HIGH-LOW)0 AND CLOSE=CB, ((CLOSE-LOW)/(CB-LOW))*((CLOSE-LOW)/(CB-LOW))*((CB-LOW)/(HIGH-LOW)*VOL) ,0);
空2:=IF((HIGH-LOW)0 AND CLOSE=CB, VOL-多2 ,0);
多3:=IF((HIGH-LOW)=0 AND CLOSEREF(CLOSE,1), VOL,0);
空3:=IF((HIGH-LOW)=0 AND CLOSE=REF(CLOSE,1), VOL,0);
多方量:=多1+多2+多3;
空方量:=空1+空2+空3;
买卖差:(多方量-空方量)/1000;
成交流通比:AMOUNT/CAPITAL/100,LINETHICK0;
内外比:DYNAINFO(51),NODRAW;
市盈率:DYNAINFO(39),COLORDDDD00,NODRAW;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和:=IF(SAT1,1,SAT)*100,COLORYELLOW,NODRAW;
中点:=REFDATE(HHV(V,N)/2,DATE);
昨日换:REF(DYNAINFO(37),1)*AA,NODRAW, COLOR0000DD;
5日换:SUM(100*V/CAPITAL,5),LINETHICK0;
DRAWTEXT(CURRBARSCOUNT=N,中点*1.3,'量能饱和度:'),COLORDDDD00;
STICKLINE(CURRBARSCOUNT=N1,中点*1.9,中点*1.5,100,1),COLOR00DDDD;
STICKLINE(CURRBARSCOUNT=N1,中点*1.88,中点*1.52,量能饱和,0),COLOR0033FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.82,中点*1.58,量能饱和,0),COLOR0077FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.76,中点*1.64,量能饱和,0),COLOR0099FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.7,中点*1.7,量能饱和,0),COLOR00DDFF;
STICKLINE(CLOSE0,【手】,0,3.6,0),COLOR00CC00;
STICKLINE(CLOSEREF(CLOSE,1),【手】,0,2.6,0),COLOR003388;
STICKLINE(CLOSEREF(CLOSE,1),【手】,0,1.8,0),COLOR00AADD;
STICKLINE(CLOSE=REF(CLOSE,1),【手】,0,2.6,0),COLOR666600;
STICKLINE(CLOSE=REF(CLOSE,1),【手】,0,1.8,0),COLOR999900;
STICKLINE(空方量,-【手】,O,3,0),COLOR005500;
STICKLINE(空方量,-【手】,O,2,0),COLOR007700;
STICKLINE(空方量,-【手】,O,1,0),COLOR009900;
STICKLINE(空方量,-【手】,0,0,0),COLOR00CC00;
STICKLINE(多方量,多方量,O,2.6,0),COLOR000099;
STICKLINE(多方量,多方量,O,2,0),COLOR0000AA;
STICKLINE(多方量,多方量,O,1,0),COLOR0000DD;
STICKLINE(多方量,多方量,O,0,0),COLORAA33DD;
版权声明

本文仅代表作者观点,不代表MY指标公式网立场。
本文系作者授权MY指标公式网发表,未经许可,不得转载。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。本站无任何QQ群微信群

分享:

扫一扫在手机阅读、分享本文