通达信荒谷流金主图指标公式

通达信指标 2019-10-09 21:00:14
N1:=3;N2:=5;N3:=9;N4:=13;
VAR1:=CLOSEREF(CLOSE,1) AND CLOSEREF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3.1,0),COLOR000055;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),2.7,0),COLOR000077;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),2.1,0),COLOR000099;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),1.5,0),COLOR0000BB;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),0.9,0),COLOR0000DD;
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),0.3,0),COLOR0000FF;
VARD:=CLOSEREF(CLOSE,1) AND CLOSEREF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3.1,0),COLOR00AAFF;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),2.7,0),COLOR00DDFF;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),2.1,0),COLOR00EEFF;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),1.5,0),COLOR22FFFF;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),0.9,0),COLOR99FFFF;
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),0.3,0),COLORFFFFFF;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORMAGENTA;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR008800;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
A1:=BARSLAST(REF(CROSS(macd.DIF,MACD.DEA),1));
DRAWTEXT(REF(C,A1+1)C AND REF(MACD.DIF,A1+1)MACD.DIF AND CROSS(MACD.DIF,MACD.DEA)0,L-0.02,'★M'),COLOR00FFFF;{MY指标公式网http://www.myzhibiao.com/}
A2:=BARSLAST(REF(CROSS(kdj.K,KDJ.D),1));
DRAWTEXT(REF(C,A2+1)C AND REF(KDJ.K,A2+1)KDJ.K AND CROSS(KDJ.K,KDJ.D),L-0.10,'◎K'),COLORFF00FF;{my指标公式网http://www.myzhibiao.com/}
A3:=BARSLAST(REF(CROSS(rsi.RSI1,RSI.RSI2),1));
DRAWTEXT(REF(C,A3+1)C AND REF(RSI.RSI1,A3+1)RSI.RSI1 AND CROSS(RSI.RSI1,RSI.RSI2)0,L-0.18,'◆R'),COLOR0000FF;{MY指标公式网http://www.myzhibiao.com/};
C1:=BARSLAST(REF(CROSS(MACD.DEA,MACD.DIF),1));
DRAWTEXT(REF(C,C1+1)C AND REF(MACD.DIF,C1+1)MACD.DIF AND CROSS(MACD.DEA,MACD.DIF)0,H+0.16,'★M'),COLOR00FF00;{MY指标公式网http://www.myzhibiao.com/};
{MY指标公式网http://www.myzhibiao.com/}
C2:=BARSLAST(REF(CROSS(KDJ.D,KDJ.K),1));
DRAWTEXT(REF(C,C2+1)C AND REF(KDJ.K,C2+1)KDJ.K AND CROSS(KDJ.D,KDJ.K)0,H+0.08,'◎K'),COLORFFFFCC;{MY指标公式网http://www.myzhibiao.com/}
C3:=BARSLAST(REF(CROSS(RSI.RSI2,RSI.RSI1),1));
DRAWTEXT(REF(C,C3+1)C AND REF(RSI.RSI1,C3+1)RSI.RSI1 AND CROSS(RSI.RSI2,RSI.RSI1)0,H+0.04,'◆R'),COLORFF9900;{MY指标公式网http://www.myzhibiao.com/};
重心:=(C+0.618*REF(C,1)+0.382*REF(C,1)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
【操盘线】:EMA(((SLOPE(C,22)*20)+C),55),COLORYELLOW,LINETHICK4;
【黄金线】:IF(重心=【操盘线】,【操盘线】,DRAWNULL),COLORRED,LINETHICK2;
【空仓线】:IF(重心【操盘线】,【操盘线】,DRAWNULL),COLORCYAN,LINETHICK2;
DRAWTEXT(ISLASTBAR,【操盘线】,'【操盘线】'),COLORRED;
{MY指标公式网http://www.myzhibiao.com/};
变:EMA(CLOSE,5),LINETHICK1,COLORYELLOW;
金:IF(变REF(变,1),变,DRAWNULL),COLORRED,LINETHICK1;
空:IF(变REF(变,1),变,DRAWNULL),COLORGREEN,LINETHICK1;
DRAWTEXT(ISLASTBAR,变,'【雷达线】'),COLORRED;
涨停:=IF((C-REF(C,1))*100/REF(C,1)=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,1,0),COLORYELLOW;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF-9.9,O,C,1,0),COLORBLUE;
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LLREF(LL,1);{MY指标公式网http://www.myzhibiao.com/}
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS=PH;
PL:=BARSLAST(TJ);
支撑:IF(BARSLAST(TJ1),
REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压力:IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;
TJ_2:=LOWREF(REF(LOW,TS),PL);
DRAWTEXT(ISLASTBAR,压力,'压力'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,支撑,'支撑'),COLOREA91B5;
{MY指标公式网http://www.myzhibiao.com/};
生命线:MA(CLOSE,26),COLORRED,LINETHICK2;
STICKLINE(C=生命线 AND C=O,H,L,0,1),COLORRED;
STICKLINE(C=生命线 AND C=O,C,O,2.5,0),COLORRED;
DP:=IF(C=INDEXC,0,1);GJ:=AMOUNT/V/100 ;
多头线:EMA(C,1.5),COLOR0000CC;
空头线:EMA(C,5),COLORMAGENTA;
均衡线:EMA(空头线,5),COLORGREEN;
VARF1:=COUNT(CROSS(多头线,均衡线),2)=1;
VARF2:=COUNT(CROSS(空头线,均衡线),2)=1;
ZAI:=FILTER(VARF1 AND VARF2,2);
DRAWTEXT(ZAI,均衡线*0.98,'↖黑牛'),COLOR00FF00;
MTM:=CLOSE-REF(CLOSE,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
DY:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX50,2) AND CROSS(MA(DX,2),DX);
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
STICKLINE(ZDF9.8,O,C,2.5,0),COLORRED;
STICKLINE(ZDF-9.8,O,C,2.5,0),COLORBLUE;
白买进:DRAWNULL,NODRAW,COLORWHITE;
黄加仓:DRAWNULL,NODRAW,COLORYELLOW;
蓝跌:DRAWNULL,NODRAW,COLORBLUE;
绿见顶:DRAWNULL,NODRAW,COLORGREEN;
红强势:DRAWNULL,NODRAW,COLORRED;
红蓝调整:DRAWNULL,NODRAW,COLORGRAY;
买进价:=((C-REF(MA(C,6),1))/6+MA(C,6))*1.004;
买进条件:=CROSS(C,买进价) AND 买进价REF(买进价,1);
版权声明

本文仅代表作者观点,不代表MY指标公式网立场。
本文系作者授权MY指标公式网发表,未经许可,不得转载。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。本站无任何QQ群微信群

分享:

扫一扫在手机阅读、分享本文