通达信绝版SB主图指标公式

通达信指标 2019-12-03 06:00:32
DA:(3*CLOSE+OPEN+LOW+HIGH)/6,POINTDOT;
DB:(20*DA+19*REF(DA,1)+18*REF(DA,2)+17*REF(DA,3)+16*REF(DA,4)+15*REF(DA,5)+14*REF(DA,6)
+13*REF(DA,7)+12*REF(DA,8)+11*REF(DA,9)+10*REF(DA,10)+9*REF(DA,11)+8*REF(DA,12)
+7*REF(DA,13)+6*REF(DA,14)+5*REF(DA,15)+4*REF(DA,16)+3*REF(DA,17)+2*REF(DA,18)+REF(DA,20))/210,COLORYELLOW;
DC:MA(DB,5),COLORRED;
{MY指标公式网http://www.myzhibiao.com/}
VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DIR1:=ABS(CLOSE-REF(CLOSE,5));
VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);
ER1:=DIR1/VIR1;
CS1:=ER1*(0.8-2/8)+2/8;
CQ1:=CS1*CS1;
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
STICKLINE(VAR2 MA(VAR3,6),LOW,HIGH,0,1),COLORLIBLUE;
STICKLINE(VAR2 MA(VAR3,6),LOW,HIGH,0,1),COLORRED;
STICKLINE(((OPENCLOSE)AND(VAR2MA(VAR3,6))),(CLOSE-0.03),OPEN,3.05,0),COLORGREEN;
STICKLINE(((OPENCLOSE)AND(VAR2MA(VAR3,6))),CLOSE,OPEN,3.05,1),COLORGREEN;
STICKLINE(((OPENCLOSE)AND(VAR2MA(VAR3,6))),OPEN,(CLOSE-0.03),3.05,0),COLORRED;
STICKLINE(((OPENCLOSE)AND(VAR2MA(VAR3,6))),OPEN,CLOSE,3.05,1),COLORRED;
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW - (LOW*0.02)),7);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH+(HIGH*0.02)),8);
PT:=REF(H,1)-REF(L,1);
CDP:=(REF(H,1)+REF(L,1)+REF(C,1)*2)/4;
AH:=CDP+PT;
AL:=CDP-PT;
NH:=CDP*2-REF(L,1);
NL:=CDP*2-REF(H,1);
强:IF(AHREF(C,1)*1.1,REF(C,1)*1.1,AH)NODRAW;
阻:IF(NH强,(强-CDP)*0.618+CDP,NH)NODRAW,COLORWHITE;
M:=IF(ALREF(C,1)/1.1,REF(C,1)/1.1,AL);
撑:IF(NLM,CDP-(CDP-M)*0.618,NL)NODRAW;
底:IF(ALREF(C,1)/1.1,REF(C,1)/1.1,AL)NODRAW;
版权声明

本文仅代表作者观点,不代表MY指标公式网立场。
本文系作者授权MY指标公式网发表,未经许可,不得转载。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。本站无任何QQ群微信群

分享:

扫一扫在手机阅读、分享本文