同花顺KDJ新改指标公式

同花顺公式 2020-02-13 21:01:18 kdj
cs=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;
a=EMA(cs,3,1);
b=EMA(a,2,1);
e=3*a-2*b;
LOWV:=LLV(LOW,8);
HIGHV:=HHV(HIGH,8);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
上:=EMA(RSV,3),colorlimagenta;
下:=MA(上,3),colorliblue;
A1:=BARSLAST(REF(CROSS(e,b),1));
底:=REF(CLOSE,A1+1)CLOSE AND eREF(e,A1+1) AND CROSS(e,b);
A2:=BARSLAST(REF(CROSS(b,e),1));
顶:=REF(CLOSE,A2+1)CLOSE AND REF(b,A2+1)b AND CROSS(b,e);
DRAWTEXT(CROSS(上,18),20,'加'),colorcyan;
DRAWTEXT(CROSS(上,78),80,'警'),coloryellow;
DRAWTEXT(CROSS(96,e) AND (e=80),60,'回调'),colorred;
DRAWTEXT(CROSS(e,1) AND (e=20),40,'反弹'),colorbrown;
DRAWTEXT(底0,-10,'kdj底'),colorgreen;
DRAWTEXT(顶0,100,'KDJ顶'),COLORFF00FF;
趋势线:MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))
*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))
*100,5,1),3,1),5),LINETHICK2,colorred;
LC:=REF(CLOSE,1);
rsi:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSIE:=EMA(RSI,3);
DIFF :=EMA(RSIE,12) - EMA(RSIE,26);
bbdIFF:=DIFF-REF(DIFF,1);
DEA :=EMA(DIFF,9);
BBDEA:=DEA-REF(DEA,1);
A3:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A3+1)CLOSE AND DIFFREF(DIFF,A3+1) AND
CROSS(DIFF,DEA);
A4:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A4+1)CLOSE AND REF(DIFF,A4+1)DIFF AND
CROSS(DEA,DIFF); 同花顺KDJ新改指标公式选股公式如下:
版权声明

本文仅代表作者观点,不代表MY指标公式网立场。
本文系作者授权MY指标公式网发表,未经许可,不得转载。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。本站无任何QQ群微信群

分享:

扫一扫在手机阅读、分享本文