同花顺定量结构指标公式

同花顺公式 2020-05-18 21:00:08 底背离 顶背离
DIF:100*(EMA(CLOSE,12)-EMA(CLOSE,26)),LINETHICK2;
DEA:EMA(DIF,9),LINETHICK2,colorred;
macd:(DIF-DEA)*2,COLORSTICK,LINETHICK3;
上翘:IF(DIFREF(DIF,1),DIF,DRAWNULL),colorwhite,LINETHICK2;
下拐:IF(DIFREF(DIF,1),DIF,DRAWNULL),colorblue,LINETHICK2;
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL20,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL30,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1CL2 ) AND (MDIFB2MDIFL2) AND (MACD0 AND REF(MACD,1)0) AND MDIFB2=REF(MDIFB2,1);
隔峰底背离:=(CL1CL3 AND CL3CL2 ) AND (MDIFB3MDIFL3) AND (MACD0 AND REF(MACD,1)0) AND MDIFB3=REF(MDIFB3,1);
B:=(直接底背离 OR 隔峰底背离);
BG:=((MDIFB2REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3REF(MDIFB3,1))*REF(隔峰底背离,1));
底背离消失:=(REF(直接底背离,1) AND DIFL1=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1=DIFL3);
STICKLINE(B OR BG,DIF,DEA,8,0),colorred;
DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.5),'钝化'),coloryellow;
DRAWTEXT(FILTER(BG,10),(DIF*1.5),'结构形成'),colormagenta;
DRAWTEXT(FILTER(底背离消失,10),(DIF+MACD),'消失'),colorgreen;
STICKLINE(BG,0,(DIF+DEA),2,0), colorred;
金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH20,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH30,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1CH2 ) AND (MDIFT2MDIFH2) AND (MACD0 AND REF(MACD,1)0) AND MDIFT2=REF(MDIFT2,1);
隔峰顶背离:=(CH1CH3 AND CH3CH2 ) AND (MDIFT3MDIFH3) AND (MACD0 AND REF(MACD,1)0) AND MDIFT3=REF(MDIFT3,1);
T:=(直接顶背离 OR 隔峰顶背离);
TG:=((MDIFT2REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3REF(MDIFT3,1))*REF(隔峰顶背离,1));
顶背离消失:=(REF(直接顶背离,1) AND DIFH1=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1=DIFH3);
STICKLINE(TG,0,(DIF+DEA),2,0), colorgreen;
STICKLINE(T OR TG,DIF,DEA,8,0),colorgreen;
DRAWTEXT(FILTER(TG,20),(DIF*1.4),'结构形成'),colormagenta;
DRAWTEXT(FILTER(顶背离消失,20),(DIF+MACD),'消失'),colorgreen; 同花顺定量结构指标公式选股公式如下:
版权声明

本文仅代表作者观点,不代表MY指标公式网立场。
本文系作者授权MY指标公式网发表,未经许可,不得转载。

文章内容来自互联网,本网站无任何收费项目也不推荐股票
广告投放请自行识别风险。本站无任何QQ群微信群

分享:

扫一扫在手机阅读、分享本文